0

I'm trying to learn how to use spatialite databases, so have made a few experimental ones. When I delete them, however, they still show up in QGIS's DB Manager. If I try to open them it comes up with a 'database does not exist' type error, but it will not let me delete them, or update itself. Worse still, I created a new spatialite layer in QGIS and named it the same as an old one (but in a different file location). Now DB manager just shows me the old one.

How can I get DB manager to update itself?

I've tried the obvious refresh button, but to no effect.

  • Can you add which version of QGIS you are using please? This could help potential answerers know if it's due to a bug for a specific QGIS version. – Joseph Nov 11 '14 at 10:15
  • And have you also tried just restarting QGIS to see if DB manager updates itself? – Joseph Nov 11 '14 at 10:47
  • Probably best to use the QGIS Browser to "delete" spatialite databases that no longer exist. Also, make sure database names are unique. – nhopton Nov 11 '14 at 12:17
  • Sorry, I'm using version 2.4.0. Yes, I have tried restarting QGIS but they are still there. With regards deleting and the answer to this question, yes deleting the database connections from QGIS browser worked, thanks. As a feature suggestion, though, it would be more intuitive if all the elements recognized what existed and what did not, if there is some way to make that work. – user39790 Nov 12 '14 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy