1

I'm using the rest API to add a feature to a public feature layer and it's giving me the error "Error: 1000, Description: The given key was not present in the dictionary". What does this mean? How do I fix?

My feature service: http://services2.arcgis.com/lfD49qylDsb6IIcE/arcgis/rest/services/PropertiesWordpressLoading/FeatureServer/0

I add my feature using this form: /services/PropertiesWordpressLoading/FeatureServer/0/applyEdits

My json: [ { "geometry" : {"x" : -86.288146369965, "y" : 32.842269287433}, "attributes" : { "CATEGORY" : 'For Sale', "LIST_ID" : '00-000', "CMN_NAME" : 'Toly Test Tract' } } ]

I get the same result if I use the form located in http://services2.arcgis.com/lfD49qylDsb6IIcE/arcgis/rest/services/PropertiesWordpressLoading/FeatureServer/0/addFeatures

2

Turns out this is an esri bug having something to do with time-aware layers. When I turned off time awareness, everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.