4

I've been trying to run a viewshed analysis in ArcGIS 10.1 and everytime I've tried running it, it crashes the whole program, with no error. See the image below.

I've made sure it has OFFSETA field in right format, that it is one point only in the shapefile, and also that 3D analyst is ticked on.

Additionally I have also tried to run it as a Python script but it still produced the same result.

The elevation and XY distances are the same unit, in metres, though I haven't specified metres in the OFFSETA column. My input layers are a DSM raster that is quite big (85000x85000 roughly, 27.23 GB), and a point layer that is one point only. They are both in British National Grid projection. Im using ArcGIS 10.1 SP 1 enter image description here

  • 2
    are your elevation and XY distances in the same unit ? – radouxju Nov 12 '14 at 15:37
  • 1
    Are you running 10.1 or 10.1 SP1? – Vince Nov 12 '14 at 16:03
  • 1
    It might help if you indicate what your input layers are. They should be in projected coordinate systems especially the raster. – johns Nov 12 '14 at 21:48
  • Have you tried running the same procedure on a smaller dataset? Please respond to this and the other requests for clarifications by editing your question to revise it with more details about your problem and steps taken to try and resolve it. – PolyGeo Nov 13 '14 at 2:41
  • Thanks for the replies. The elevation and XY distances are the same unit, in metres, though I haven't specified metres in the OFFSETA column. – TheMole Nov 13 '14 at 9:59
2

I was just having this exact same problem. The whole ArcMap program would crash as soon as I started to run Viewshed and no error was returned. I tried the tip offered by @PolyGeo to try a smaller dataset, so I clipped my DEM to a smaller extent and ran the tool again with the new, smaller raster. This time it immediately worked without a problem. (yay!)

One related question to the comment offered by @radouxju: In many of the threads I came across trying to solve this problem, someone suggests making sure that the elevation (Z) and XY distances are in the same unit, but as far as I can tell, this isn't an issue if you use the Z factor to compensate for different units. My DEM had XY units in meters and Z units in feet, but I entered a factor of 0.3048 to let the tool convert units on the fly.

  • 2
    While it shouldn't crash, are you actually getting anything worthwhile on a viewshed with a raster of say 100km, even 50km might be a stretch. A best practice is to use Buffer to set an extent and a mask to limit processing to a given radius. Download the GPK from here and see the work flow: arcgis.com/home/item.html?id=cede8ab5c0514f41a2cc69bedff67f48 – KHibma Jun 10 '15 at 13:40
  • Thanks for the best practices tip. For my purpose, I didn't need a viewshed extending out 100km, and about 50 km would certainly be sufficient. At larger extents, it probably would have been acceptable to use a coarser resolution raster as well. – Leo Jun 10 '15 at 13:57
1

I have two suggestions:(1) Place your inputs in a folder on your desktop. The point is to have a short folder path. Your inputs will be a raster DEM and a point or polyline shapefile. (2) Avoid using numbers or capital letters when naming your output (the viewshed). This has worked for me so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.