1

I need to create my own mapsforge map file...

  1. My system is Ubuntu 14.04.1 LTS
  2. I've installed osmosis via apt
  3. Since link in official documentation is not working i've found plugin file here and downloaded it
  4. Following this documentation I placed file in ~/.openstreetmap/osmosis/plugins/
  5. Downloaded osm.pbf file from geofabrik
  6. Run

    osmosis --read-xml file=poland-latest.osm.pbf --mapfile-writer file=test.map

And i' getting this error:

lis 17, 2014 10:40:02 AM org.openstreetmap.osmosis.core.Osmosis run 
INFO: Osmosis Version 0.40.1 
lis 17, 2014 10:40:02 AM org.openstreetmap.osmosis.core.Osmosis run 
INFO: Preparing pipeline. 
lis 17, 2014 10:40:02 AM org.openstreetmap.osmosis.core.Osmosis main 
SEVERE: Execution aborted. org.openstreetmap.osmosis.core.OsmosisRuntimeException: Task type mapfile-writer doesn't exist.
        at org.openstreetmap.osmosis.core.pipeline.common.TaskManagerFactoryRegister.getInstance(TaskManagerFactoryRegister.java:60)
        at org.openstreetmap.osmosis.core.pipeline.common.Pipeline.buildTasks(Pipeline.java:50)
        at org.openstreetmap.osmosis.core.pipeline.common.Pipeline.prepare(Pipeline.java:112)
        at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:86)
        at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:37)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:483)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:328)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:238)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:408)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:351)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:31)

Seems like osmosis don't see the plugin, but i've done everything according to docummentation... I've also tried to place plugin file in other localization (/usr/share/osmosis, /usr/share/osmosis/plugins), but still not works..

What am I doing wrong?

2

I've found an answer...

Following another documentation i've placed plugin file in sub-folder /plugins in current folder - it works.

  • @AndreJ - of course - sorry :/ – Jendrusk Sep 25 '15 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.