1

Iyi gunler Cem Bey, I have just installed QGIS 2.6 (Brighton) on my PC (Bootcamp) running Windows 7 and would like to try out FlowMapper. However after I have loaded it I received the following error:

Error Loading Plugin The plugin seems to be invalid or have unfulfilled dependencies. It has been installed, but can't be loaded... Here is the error message below:

The plugin is broken. Python said: ascii

Can you please help me solve this riddle?

  • I'd start python console and 'import ogr' command give errors! It's not a flowmapper pluging error seems more deeply programs. – user41151 Nov 26 '14 at 13:18
2

Resolved! It's a module PATH Python console problem.

In QGIS Brighton/apps/Python27/Lib/site-packages create osgeo.pth (Administrators) file and put

# .pth file for the osgeo extensions osgeo

start QGIS and install flowmapper ;)

1

Merhaba Başak Hanım,

You could try manual installation if you are experiencing issues with automatic installation by using QGIS Plugin Manager.

FlowMapper is designed to be compatible with Windows, MacOS* and Linux platforms. It other words it has cross platform support. (*filtering options do not work under macos unless gdal/ogr dependencies are installed)

To manually install FlowMapper please copy FlowMapper folder under the OS specific path given below. Afterwards, restart QGIS and enable the plugin from plugin manager.

Windows:
C:\Users\$USERNAME.qgis2\python\plugins\
or
C:\Program Files\QGIS Dufour\apps\qgis\python\plugins\

MacOS:
./Users/$USERNAME/.qgis2/python/plugins/
or
./usr/share/qgis/python/plugins/

Linux:
home/$USERNAME/.qgis2/python/plugins/
or
./Applications/QGIS.app/Contents/Resources/python/plugins/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.