0

I'm finishing an analysis of approximately 850 archaeological assemblages in the Mediterranean, and I've successfully run IDW in Geostatistical toolbox (ArcGIS 10) to generate the results I like. I'm using the Geostatistical toolbox as I'm interpolating the values of polygons, not points. I'm trying to limit the extent of the results to the bounds of the Mediterranean Sea, however, but adding the mask to the appropriate dropdown box in IDW > Environments > Raster Analysis makes no difference to the extent of the interpolated results.
I tried Diffusion Interpolation with barriers, but that didn't provide the appropriate results visually, and I tried Extraction (Spatial Analyist > Extraction > Extract by Mask) as well. The latter provided me with results within the geographic bounds I wanted, but appears to have reinterpreted my raster and is displaying the results in black-and-white - my original IDW results disappear. At this point, I'm simply importing the resulting rasters into Photoshop and masking them there, but that can't be right. Is there a way to mask IDW in the Geostatistical toolbox that I'm missing?

4
  • do you want a visual mask or that IDW don´t include the water into the process?
    – Pau
    Commented Nov 19, 2014 at 15:46
  • Hi Pau, it's the second option in a way. I don't want the interpolated results to extend onto the land, but I do want them on the water. But simply limiting it visually would be fine.
    – Matthew
    Commented Nov 19, 2014 at 17:47
  • Hi, visually you can create a raster of the edge of the water, then reclassify water = 0; land = 1. After use raster calculator and multiply the IDW and the mask.
    – Pau
    Commented Nov 19, 2014 at 19:18
  • Hi Pau, I'll give that a try and let you know what happens. Fingers crossed. Thanks for your help.
    – Matthew
    Commented Nov 19, 2014 at 20:24

1 Answer 1

1

This is just how it works. Your extraction by mask is just fine, you merely need to change the symbology in the extracted raster. The mask is not doing what you (or I) think it should in the environments setting. It is more of an envelope when used here as opposed to a true "cookie-cutter" when you are using extract by mask. FYI this never used to happen in the Geo Analyst toolbar in earlier versions but does in the Toolbox. Do not worry just extract by mask your results and then re-render the black and white raster. You can even put the Extarct by mask in a model so it appears automatic.

1
  • Hrmmm, I think I follow what you're suggesting. I'll give that a try as well and see what emerges. Thanks for this idea too.
    – Matthew
    Commented Nov 20, 2014 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.