1

My organization uses several address locators stored in SDE. The server license was recently updated, and shortly after, some of these locators simply disappeared -- they are no longer visible or accessible to ArcCatalog, Python, etc., and the underlying SQL Server shows no corresponding tables. However, trying to create a new locator with the same name fails with the message that it "already exists." Has anyone experienced a similar issue or have some other suggestions to either delete or restore these missing locators?

0

There are several underlying related tables in SDE that have a chance of not being updated properly if the table delete happened nontraditionally. The most likely cause of this issue is that the table name is persisting in the table registry even though the table has been deleted from SDE.

First, run a SELECT * on [database].[schema].[SDE_table_registry]. There is a good chance you will see your address locator names in that table. If so, you can follow this procedure:

  1. If archiving is enabled, disable archiving
  2. If versioning is enabled on the table, unregister as versioned

run this SDE command to delete the table from the registry (substituting in your table information):

sdetable -o unregister -t av.world -u av -p mo -i 7654

If this does not work for you an alternative workaround is to create a dummy table of the same name using SQL:

CREATE TABLE [NAMEOFLOCATOR_LOX]
(
     objectid INTEGER NOT NULL
)

Address locators in SDE follow the convention [name of locator]_LOX. After you create the table, delete it from ArcCatalog. ArcCatalog will know to remove the requisite table and column registries from the back end, freeing up the name for you to use again.

1
  • Un?fortunately, the server was restarted before I got your solution, apparently clearing out those lingering traces and allowing us to recreate our locators. I've selected your answer for the in-depth information and because it's very possibly what caused our issues, but we may never know for sure (unless it happens again). Nov 24 '14 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.