1

anyone can give me an explanation about how to integrate spatialite with php(sqlite3)-windows platforms.

I have tried to refer from this link http://www.gaia-gis.it/spatialite-2.4.0-4/spatialite-cookbook/html/php.html

But I do not understand is why the error message appears as follows.

"Warning SQLite3::loadextension(), Not supported in multithreaded Web Servers"

i use libspatialite-2.dll

1

The message is explicit. Your server settings does not support loading extension from script like so :

$db->loadExtension('libspatialite.so');

See if you could load it directly from the php.ini

4
  • i've done the configuration in php.ini, i edited a sqlite3.extension_dir=libspatialite-2.dll but it's just stay the same error messages. If i write the wrong code on it? Another info, i use xampp 1.7 – dityagow Jul 16 '11 at 17:38
  • you must restart apache – simo Jul 16 '11 at 20:58
  • i've already include it, in my way to edit the php.ini always restart my apache. but whether the problem was appear is because i using xampp, not using a php and apache which are mutually exclusive (separated each of them)? – dityagow Jul 17 '11 at 5:16
  • check if enable_dl = On is uncommented on your php.ini. If it is and it does not still work I guess you would have to install Apache and PHP manually (which is not a big deal ....) – simo Jul 17 '11 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.