1

I have enabled disk quota to cache tiles that produced by WMS. Geoserver admin panel Tile Caching->Tile Layers list of cached layers. I can preview here on a demo page.

http://localhost:8080/geoserver/gwc/demo/pgs:topas?gridSet=EPSG:4326&format=image/png

After preview I see that disk quate increased. This works fine.

I am using my layers on my OpenLayers application but used disk quata is not increasing. application is using url: http://localhost:8080/geoserver/wms/..... Used tiles are not inserting to disk. Why does not this?

(I have enable Tile Caching->Caching Defaults->Enable direct integration with GeoServer WMS)

  • What url is your app hitting? – Ian Turton Nov 20 '14 at 14:23
  • I updated also question localhost:8080/geoserver/wms... – boliwe Nov 20 '14 at 14:26
  • 1
    You need to either hit the gwc url or match yor tiles to the gwc grid (unlikely by chance) – Ian Turton Nov 20 '14 at 14:28
  • I set my custom projection as EPSG:99100 in epsg.properties file. I could not found geowebcache.xml in my server. should I create geowebcache.xml? I see only gwc-gs.xml in /geoserver/data path – boliwe Nov 20 '14 at 21:10
2

The chances are your OpenLayers application is requesting data in as a regular WMS request.

The following options will let you fix it:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.