6

Just got QGIS 2.6.0 running on Windows 7 service pack 1 64 bit. Project loads, edits, saves editing changes, adds removes, layers no problem. Only problem is saving the project. Do that and it's certain death. You get a mini dump crash error.

Then you attempt to open the project again and it says unexpected end of file at line'x' and shows the file as being 0 KB. Restore the project to a previous version and it happens again EVERY TIME. This also happened when I upgraded to 2.4. What gives? Yes, going to be writing a bug ticket also.

7
  • I see this minidump too - ticket was closed hub.qgis.org/issues/10756
    – Mapperz
    Nov 20 '14 at 18:32
  • I had previously tried all those suggestions and nothing worked. Is this the new norm every time a new version comes out or what?
    – Karl Mohr
    Nov 20 '14 at 19:01
  • 1
    We had similar problems after updating to 2.6. One thing you can try is to open the project in 2.6 and save it under a new file name, instead of saving to the same file. Also, we've since switched to the development version (2.7), which seems more stable in this regard.
    – Jake
    Nov 20 '14 at 20:04
  • Did you try removing all your plugins? gis.stackexchange.com/questions/107617/…
    – johns
    Nov 20 '14 at 21:06
  • The same here. Win 7 Pro x64 with Qgis 2.6.0. Uninstall of Metasearch Catalog Client plugin solved the problem. Nov 21 '14 at 10:04
6

I have had this problem with each generation of QGIS and windows 7,8, and 10 Today I solved it!!! I deleted the .qgis2 folder in my user path Simple as that. When QGIS opened it created a new .qgis folder and will now happily and gracefully exit. :-)

3
  • Its works !!! but you need to re-install necessary plugins..
    – Sunil
    Nov 16 '15 at 7:27
  • This was happening with QGIS 2.12 and 2.14. I'm running them on Win10, 64bit. Deleting the .qgis2 folder worked for me. It seems I should delete this folder whenever I install a new version of QGIS...
    – cndnflyr
    Mar 2 '16 at 20:56
  • I had this issue on 2.18 primarily when zooming in and out on print composer. Deleting the .qgis2 folder seems to have worked! Thanks!
    – jm90
    Aug 1 '17 at 3:41
2

I had the same problem on QGIS 2.6 64 bit on Windows 7 Home Premium with all current updates.

Crashed on saving, every time, minidump and project file saved as 0 kb file or with small invalid file.

Uninstalled metasearch catalog client and solved problem.

0
2

There were some issues with QGIS 2.6 crashing with old projects and the print composer:

http://hub.qgis.org/issues/10756

https://hub.qgis.org/issues/11685

You can try the latest dev build, which has some bugs fixed, or take the bugfix release 2.6.1 which is just released.

Creating a new project from scratch should be save.

0

I just deleted .qgis2\python\plugins and eveything went just fine. Removing everything would make me lose recent projects list, custom expressions/functions/scripts which I rather keep.

1
  • What plugins did you have before? Aug 25 '17 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.