2

I have problems using the gdal modules extract and warp in the modeler. They run correctly when started without the modeler, but when I integrate them in the modeler they won't work. The only input I do set is the raster layer.

The process ends with the known remark:

"Oooops! The following output layers could not be open Output Layer: C:\Users\sven\AppData\Local\Temp\processing\d2999fed6cd643a280f809eb0bee2373\OUTPUTALG0.tif The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm Checking the log information might help you see why those layers were not created as expected"

The Log states everything is OK and ends with:

"Executed 1 algorithm total. Converting outputs. Loading resulting layers"

(If more information is needed ask for it)

The ogr-protocol states that the "data source is invalid"

As mentioned everything works fine, if I dont use the modeler.

  • In the model, have you tried setting the result to save as a file and not as a temporary file? – Joseph Dec 2 '14 at 11:59
  • Yes, and both produce the same error. – gilla Dec 3 '14 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.