2

I am trying to converta batch of ecw aerial photos to jpg in arcmap using the ( Raster to other format) but each time it converts 4 or 5 images and then fails and show this message. enter image description here

i tried to convert them using FME and the issue still there, Is there any method to convert the photos using arcmap and what might be the issue with them. i tried to do the same operation on more than one PC and the issue is the same. any suggestions??

  • Just guessing: Do you enough have space in the system disk? Perhaps batch process does not clean some temporary files. I suppose you have already tested that images are OK and you can convert them one by one. – user30184 Nov 21 '14 at 15:06
  • Thank @user30184 , I have more than 140 GB free on my disc. on the other hand i have more than 100 photos , i tried to convert 10 each time but the issue still there . – Ahmad saleh Nov 21 '14 at 15:16
  • If it not essential to use ArcMAP and FME you can download GDAL package from gisinternals.com/sdk, create a batch file and convert your images with gdal_translate. But you should not convert them to jpegs which is an useless format for aerial images because the whole jpeg must be decompressed even if only tiny bit from the middle is needed. FME is a high quality program and I suppose there is something special in your images or hardware but it does not hurt to try GDAL before more deep debugging. – user30184 Nov 21 '14 at 15:26
  • Iam going to try it , thank you for your time and help . – Ahmad saleh Nov 21 '14 at 17:07
1

If two sets of software (FME and ArcGIS) are throwing up an error (does FME report an error in the log or does fme.exe just crash?) and you've tried two different sets of hardware, then you've got to suspect maybe a corrupt file.

Can you try converting the 4th/5th one by itself, to see what happens?

I suppose it could be a bug in a component common to both FME and ArcGIS, but I can't think of anything they would share except, ironically, maybe GDAL libraries!

  • hello mark , the FME report the error and stops converting but it doesn't crash , all the answers around the web says that ArcGIS have a problem with some versions of ECW images (v1 and v3) and it works smoothly with v2 , i have noticed the bad behavior of arcmap with ecw not only in converting but also in building overviews in the mosaic datasets . but I am still searching why FME fails to convert, i solve that problem in converting using erdas and arcmap ( ecw to img in erdas ) and then ( img to jpg in arcmap) I lost to much of my time doing this . Thank you mark for your help – Ahmad saleh Nov 25 '14 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.