5

I am having the issue where the International Dateline is splitting a polygon I am working with. I have a layer of the "Federal Districts" of Russia, and the eastern most federal district is being "cut" by the international dateline.

I currently have the data frame's coordinate system set to Asia Lambert Conformal Conic and this places the two "cut" polygons next to each other (how they should be). I really need the polygon to not be cut and show as a continuous polygon.

I've researched up and down, tried changing the projection/coordinate system, but with no luck.

I've attached a screenshot of the one multi-part polygon that is being split by the international dateline. I would like it so that there is no cutting of the polygon, and therefore no boundary line going through the polygon.

I've even tried transforming this multi-part polygon into separate, single-part polygons, then merge them back together, but anytime any part of any polygon crosses this line, it gets cut.

Layout View:

russia issue

Data View: enter image description here

  • Do you mean that your starting polygons are already "cut" and you are trying to combine them? Or do they look OK before you run some geoprocessing and the subsequent product has the "cut"? – Conor Nov 21 '14 at 19:20
  • Hi! Thanks for your response. Yes, the polygons are already "cut" and I am trying to combine them. – Jaimie Nov 21 '14 at 22:37
9

If you reproject the polygon data to Asia Lambert Conic (not just On-the-fly, but really reprojecting all vertex coordinates into a new file), you can dissolve the polygons by a common attribute.

This should remove the common border line. If it does not work in first run, have a closer look at the border line. There may be a small gap after the reprojection, if the border does not share the same vertices. Snapping before dissolving should fix that.

I got this result:

enter image description here

  • Thank you so much! I just had to use the Project tool, then fix some vertices, and the cut line disappeared as I fixed them. I appreciate the help! – Jaimie Nov 24 '14 at 14:02
0

In ArcGIS.

Start Editing the polygon layer.

Select the two polygons only, one each side of the international dateline.

In the dropdown Editor menu will be a merge option, click it.

A window will appear select the portion of the polygon you want the other part to become a part of (usually the bigger one), they flash as you select them.

You now have one polygon.

Save edits

  • Thank you for your reply! Unfortunately, for this situation that didn't work work because it was actually just one polygon, being split by the dateline. Much appreciated! – Jaimie Nov 24 '14 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.