I'm using QGIS 2.6.

I'm trying to clip the polygons in one layer by another but cannot get the results I expect. I have a layer with wetland areas, and another layer with the boundary of my client's property. I want a layer showing only those wetland areas that lie within my client's property. If I run the 'Clip' tool, the resulting layer has nothing on it. It makes no difference which layer I use as the input layer and which as the clip layer, the result is always no features.

Could anyone explain what's going on and what tool might do this operation if not 'Clip'?

  • Thanks, the two layers were of different CRS, I was presuming that OTF re-projection would rectify that difference. Saving one of the layers in the same CRS as the other has solved the problem. – user39790 Nov 23 '14 at 10:21

Turn On-the-fly-reprojection OFF and see if the layers still align.

If not, save one layer to the CRS of the other using Save As ... under a different filename.

Clipping does not work if the layers have different CRS.


If the Reference System for the shape is equal, you can use "intersect" tool (vector>geoprocessing tools>intersect). The vector result have, in the attribute table, the values of two vector that you have processed (wetland areas and boundary).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy