Using ArcGIS Desktop 10.2, I would like to build a network dataset that that includes a line shapefile representing train lines and a point shapefile indicating train stations along those lines. When I right-click on the Personal Geodatabase I'm working in, and select "Create a Network Dataset," the only shapefiles that show up to be selected for inclusion in the Network Dataset are the line shapefiles within the Personal Geodatabse, but not the point shapefile I would like to use for train stations in the dataset. Here are some screenshots:

Personal GDB in TOC Network Dataset dialog box

Is it possible to include points within a Network Dataset like this?

I thought I was able to do so before, but for some reason I seem unable to include the train stations along with the train lines.

  • Yes, point features can be added as junctions to a NDS. I note that none of your point layers or your CTA_Routes_1 layer are showing up. Since they're all already in the FDS that would indicate they're in the same CRS. Have you run Integrate to ensure all of the layers have shared vertices as necessary? Note, those are feature classes, not shapefiles (which wouldn't work). Note that you only need to load them to the NDS if they are to serve as multi-modal junctions. If they're just locations/stops, they gets added as part of the actual analysis and not the NDS. – Chris W Nov 23 '14 at 0:11
  • That is weird. I vaguely remember putting barriers, sources, sinks and stop points on a hydrological network in 9.3.1 but when I tried this on some random data I have lying around the points didn't show up. This may be a bug that Esri support may be interested in. The default junctions are created but barriers/stop points/sources/sinks can't be added. Can you show the properties of ctaBus_ND with the points included? Neither in Geometric Network or Network Dataset. – Michael Stimson Nov 24 '14 at 0:50
  • @MichaelMiles-Stimson I was seeing something similar in some tutorial data I have on hand - some layers in the FDS were listed to add to the NDS, some were not. The only thing I could find skimming tutorials was a section to ensure there were coincident vertices in both the line and point layer. I remember successfully doing the tutorial, so I must have gotten it all added at some point. I stepped through the NDS creation and didn't see anything special about making it multi-modal, though I did note you could later add more layers to the NDS after creation. Not sure if that would solve it. – Chris W Nov 24 '14 at 23:36
  • I tried that @ChrisW, the layers that were available at creation were available to include later (minus the ones that were already included). I have dredged up the network I created previously and seen the sources/sinks/junctions included. I will try to export the raw data to a new database and see if the points come up then. Update: copying the features to a new database the points were available what's up with that??? – Michael Stimson Nov 24 '14 at 23:49
  • 1
    OK, I found out why the points didn't come up, because they were MULTIPOINT features - not points, which cannot participate in a geometric network forums.esri.com/Thread.asp?c=93&f=1733&t=228177 and presumably a network dataset also. Please check your points are not multipoint (you can make multipoint into points using Multipart to Single part resources.arcgis.com/en/help/main/10.1/index.html#//…) – Michael Stimson Nov 25 '14 at 0:04

Based on the comments and with help from ChrisW it was determined that the points were unavailable to participate in the Network because they were of geometry type multipoint (multiple points for a single row):

A Multipoint geometry represents an unordered collection of single locations in space, and can be used to represent geographical features which have multiple single locations but which represent a single geographical feature, for example the multiple entrances to a single rabbit warren

Which cannot participate in a network, according to the help document for creating a geometric network:

Only point and line feature classes are supported as input. The feature classes cannot participate in another geometric network or other advanced geodatabase dataset such as a topology, network dataset, terrain, or fabric.

Datsets will be unavailable to include in a network if:

  • The feature class is not in the same feature dataset or external to the database.
  • The feature class participates in a database Topology.
  • The feature class is already in another network (either network dataset or geometric network)
  • The geometry type is not point or line

To convert multipoint features into point features use the Multipart to Single Part geoprocessing tool.

In catalog it is difficult to discern a multipoint from a point:

enter image description here

Even though I know that POINTFEATURES are points and REVTABLEPOINT are multipoint features they look identical. You must right click on the dataset and get the properties to find out if the features are point or multipoint.

Multipoint features:

Example of multipoint

Point Features:

Example of point

I have seen that when data is imported from MapInfo TAB and some CAD formats the points will be imported as multipoints, mostly with a single point for each row, to avoid the possible loss of geometry during import.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.