2

I am using QGIS 2.4 on Windows 8.1. I have a project in which I have been digitizing from OpenMaps. Last night I was doing some more digitizing, saved, and closed the program. When I opened it this morning, my layers (.shp) were not projected properly, even though they were when I saved and exited. I closed, and re-opened, and they were projected properly (so weird thing #1). However, when I went to go back to digitizing, I noticed that I have some features of a layer showing up that do not exist anymore (I deleted them yesterday). These features show up only at certain zoom levels, and are not selectable. Screenshots attached.

Any idea what this means?

enter image description here

enter image description here

"Phantom" features, in the "Brush" layer. The first image is what it SHOULD look like, and the second image is what I see when I zoom out. This is happening in other layers as well.

5
  • 1
    There might be a spatial index on the shapefile that makes those old deleted features to show up. – SaultDon Nov 23 '14 at 0:12
  • Thanks for the suggestion. Off to google to see what a spatial index is! – user32690 Nov 23 '14 at 0:49
  • 2
    You can try backing up the shapefile, then loading a new copy that's made up of only the files that end in .shp .shx .dbf .prj - delete all the other files that aren't in that list. – SaultDon Nov 23 '14 at 1:04
  • Unfortunately this did NOT work. Thank you for the suggestion. I also tried using "save as" on the .shp, but alas the new file has the same issue. – user32690 Nov 23 '14 at 1:26
  • The last thing I can think of is to uncheck the Render Caching... option in the Settings > Options > Rendering panel and test with that. – SaultDon Nov 23 '14 at 1:52
4

The "Phantom" feature likely is an invalid one, you should try to make valid it. To fix the feature you can:

  1. use the Check Geometry tool (Vector->Geometry tools->Check Geometry Validity). This allows you to find invalid geometries. In this case you have to fix the feature manually by editing it.

enter image description here

  1. use the Processing LWGEOM plugin: Plugins->Manage and Install plugins and searching for "lwgeom". The plugin has to be configured from Processing->Options->Provider->LWGEOM algorithms and setting the Path to liblwgeom library. The lwgeom library may be installed from OSGeo4W installer. In Windows it is named liblwgeom.dll (liblwgeom.so for Linux). Once configured run the Make Valid algorithm by the Processing Toolbox in order to valid your layer.

enter image description here

There would be also the Topology checker plugin (Vector->Topology Checker), but the tools mentioned above should be enough to track and fix the problem.

The problem with the CRS is odd, you could try to fix the layer before and maybe the problem will disappear. Hope this helps.

1
  • Thank you! I was able to use a combination of validating the geometry with the topology checker to select and delete for good the offending features! – user32690 Nov 23 '14 at 22:47
1

Try to copy your shapefile into a new one with ogr2ogr and see if that helps. This QGIS issue is about phantom features http://hub.qgis.org/issues/11007. However, the problems described in the ticket appeared when opening shapefiles which were saved by QGIS with another program and not with QGIS itself. It will not hurt to try, though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.