1

I'm trying to test an mxd with mxdperfstat.

I want to test several scales, but as soon as I provide a scale over 500, the program simply quits. No Error warning. It just stops working. If I provide several scales at once (250;500;800;1000) it tests the 250 and 500 and then stops.

I use ArcGIS 10.2.2 and the according mxdperfstat10.2.exe. Thats how I call the programm: mxdperfstat10.2.exe -mxd F:\Path\test.mxd -scale 250;500;800;1000 -xy 4348929;5498749 -width 1000 -height 1000

The end of the console output looks like this:

21.11.2014 13:25:18 RunTest:LoadXML
21.11.2014 13:25:18 RunTest: ESRI.ArcGIS.ADF.COMSupport.AOUninitialize.Shutdown()
21.11.2014 13:25:18 RunTest: ESRI.ArcGIS.ADF.COMSupport.AOUninitialize.Shutdown() Completed
21.11.2014 13:25:18 RunTest:Application.Exit()
21.11.2014 13:25:18 After RunTest:Application.Exit() 

No error is documented.

In the resulting .xml report there are only the test values for scale 250 and 500. The behavior is the same for different MXDs.

Any Idea what the Problem could be here?

1 Answer 1

1

After a lot of experiments I found the problem:

When I worked with the MXD in ArcMap the Scale 1:651 was set.

Every attempt, to run perfstat with a scale higher than 650 failed.

After I zoomed out to a higher scale in ArcMap and saved the mxd again, I was able to run perfstat with higher scales. But only up to the scale, that was set when I saved the MXD.

Seems like a bug to me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.