1

I downloaded and installed Java SE Development Kit 7u71 and Apache Tomcat (since JDK7u71 contains JRE, so I didn't download Java SE Runtime Environment 7u71). No problem with Apache Tomcat. Then I downloaded and installed GeoServer 2.6.1 (Windows Installer,Run manually), the wizard found automatically the JRE path: C:\Program Files\Java\jdk1.7.0_71 (I checked it, there is a JRE file in jdk1.7.0_71). After this I tried to run GeoServer,but it didn't work.

I then checked Environmental Variables, there was no JAVA_HOME, so I added it with value C:\Program Files\Java\jdk1.7.0_71. Then I restarted my computer, GeoServer still didn't work. Then I changed ‘GEOSERVER_DATA_DIR’ system variable to C:\Users[MY USER NAME HERE]\AppData\Roaming\Geoserver\data_dir, and restarted my computer, still, GeoServer did not work.

What could be the problem? How can I make GeoServer work? Any help?

enter image description here enter image description here enter image description here enter image description here

  • 2
    The Windows installer installs a Jetty server so Tomcat is not involved except if it is running in the 8080 port then it probably prevents Jetty and GeoServer from starting. In the "Run manually" mode GeoServer is started from geoserver-2.6.1\bin\startup.bat. What is the error when you do run the batch file? – user30184 Nov 24 '14 at 18:00
  • @user30184 Hi, I edited my question so you can see the file. – ZhangYao Jiayin Nov 24 '14 at 20:16
  • You can read there: Address already in use. I bet that your Tomcat is running in localhost:8080. Stop it if you want to use GeoServer like you have installed it now with Jetty that also wants to run in 8080. Alternatively if you want to use Tomcat you must install GeoServer from WAR archive. – user30184 Nov 24 '14 at 21:27
  • 1
    However, you can also let Tomcat to run in 8080 if you need it for something else. Uninstall GeoServer and re-install. Installer asks which port the Jetty server should listen. Configure it to use for example port 8090 and everything should be fine. – user30184 Nov 24 '14 at 22:33
  • @user30184 It works now! Thanks a lot for your help! – ZhangYao Jiayin Nov 25 '14 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.