0

I'm new in GIS and i'm starting to use pywps. I write THIS process but doesn't work. It returns this:

Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/pywps-3.2.2-py2.7.egg/pywps/Wps/Execute/init.py",
line 387, in init self.consolidateInputs()
File "/usr/local/lib/python2.7/dist-packages/pywps-3.2.2-py2.7.egg/pywps/Wps/Execute/init.py",
line 547, in consolidateInputs
raise pywps.MissingParameterValue(identifier)
MissingParameterValue: < ?xml version="1.0" encoding="utf-8"?>
< ExceptionReport version="1.0.0" xmlns="http://www.opengis.net/ows/1.1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/ows/1.1 http://schemas.opengis.net/ows/1.1.0/owsExceptionReport.xsd">
< Exception exceptionCode="MissingParameterValue" locator="text"/>

How can i fix this?

4
  • Hi, have you tested also the GetCapabilities and DescribeProcess request?
    – doktoreas
    Nov 24, 2014 at 22:05
  • Yes, I tested and it seems alright...
    – MarcoPSM
    Nov 25, 2014 at 11:00
  • Can you post the Execute request? It seems that you are not providing the "text" parameter.
    – doktoreas
    Nov 25, 2014 at 14:32
  • request: http:// localhost/cgi-bin/pywps.cgi?VERSION=1.0.0&REQUEST=Execute&SERVICE=WPS&IDENTIFIER=firstprocess
    – MarcoPSM
    Nov 25, 2014 at 16:22

1 Answer 1

0

You are missing the datainputs. Take a look here for an example using KVP request. You can also test the WPS service using the QGIS WPS plugin.

2
  • added the following &DataInputs=[text1=Marco] and it worked thanks!
    – MarcoPSM
    Nov 25, 2014 at 19:19
  • Hi, if this or any answer has solved your question please consider accepting it by clicking the check-mark. This indicates to the wider community that you've found a solution and gives some reputation to both the answerer and yourself. There is no obligation to do this.
    – doktoreas
    Nov 25, 2014 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.