6

As far as I know Geoserver web administration page language depends on the language settings in browser. So if my preferred language is Russian I see partially translated page, and if I need it in English, I just set English before Russian in browser settings.
Is there any way to override this behavior by editing some xml config or properties file? I need admin page to be always displayed in English, regardless of user browser language.
I am using Geoserver 2.6.1.

  • It will always use your browser locale. – Ian Turton Nov 27 '14 at 13:42
  • I have installed windows server English and browser language is english, but location is turkish. But geoserver admin UI language is Turkish. – boliwe Feb 12 '15 at 14:56
1

There is no way to do so, the oldest GeoServer open ticket is actually about it: https://osgeo-org.atlassian.net/browse/GEOS-315

Process to get it implemented, if you are interested, is here: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer

  • So how about now? Did they change this, because it is still annoying. – botenvouwer Sep 12 at 11:36
  • 1
    No funds ever showed up, did not happen. Can still be done :-) – Andrea Aime Sep 12 at 15:45
0

GeoServer uses the java locale system to automatically choose the display language. My system is installed in English and still it figured out that my native language is Dutch.

You can overrule the default java locale, in my case for windows:

java -Duser.country=NL -Duser.language=en -Duser.variant=Traditional_WIN

Then restart GeoServer, and check if the admin page shows in english. Also make sure your browser is set to English.

  • Sadly this does not seem to do much for a system installed in German. At least when I pass them in CATALINA_OPTS. – bugmenot123 Oct 28 at 16:16
  • @bugmenot123 Pass them to java, like I do. – botenvouwer Oct 29 at 7:27
  • You ran this just once globally on your system? I thought those were runtime changes. – bugmenot123 Oct 29 at 14:41
  • Yes indeed you run it just like that and it should change the settings globally. You will need to restart your service. – botenvouwer Oct 30 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.