18

I'm having a problem with the mouse wheel zoom setting on my macbook trackpad. The zoom occurs far too quickly for any level of precision. I noted this comment in the dev log:

2004-08-14 [gsherman] 0.4.0devel9 Added mouse wheel zoom. Moving wheel forward zooms in by a factor of 2.

How can I change the settings so that zooming occurs by a factor of 1 or .5?

I'm using QGIS 2.6 Brighton.

3 Answers 3

22

Open Preferences > Options menu and go to "Map Tools" (see the screenshot below). The Zoom factor will be available on the main window.

For QGIS v3.X provide a zoom factor in percentage :

Zoom wheel QGIS3

For QGIS v2.X, just provide a ratio value : Zoom wheel

Notice that the minimal value is 1.1 ... 1 would just do nothing and a value < 1 would unzoom.

2
  • 4
    Thank you for this information. Currently I am using 2.14.3 Essen and a zoom factor of 1.1 is my sweet spot for zooming with a apple trackpad.
    – Gert
    Jul 6, 2016 at 9:09
  • 2
    110% for QGIS3, where the values are percentages instead of proportions Jul 19, 2018 at 23:22
3

For QGIS3

setting > option > map Tools > zoom factor

QGIS3

0

If you zoom out too far and lose your layers, you can right-click on a layer in the Layers Panel and select Zoom to Layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.