2

I use Geoserver + Openlayers and want to add and save some new Points via WFS-T. I created insert transaction (correct) and sent it, but no response (include errors) was returned. In console was only:

01 dec 17:34:16 INFO [geoserver.wfs] - Request: getServiceInfo

I tried to execute demo insert transaction but had same result. what am I doing wrong? Geoserver 2.5.3, Tomcat 7

  • Working from the browser up through the stack... 1. <strike>What is the HTTP status of the response? I don't have a WFS-T service set up at the moment, but I would expect a 201 response (resource created) or a 200 response (OK).</strike>. I almost forgot that GeoServer happily serves up status 200 responses for almost everytyhing so the HTTP status probably won't be much help. 2. What do the GeoServer logs say? Can you change the log level to verbose temporarily if it's – stuporglue Dec 1 '14 at 12:17
  • I change level to TRACE but same situation with no response. And have no response code cuz geoserver not response. I do test transaction from demo page in Geoserver. And delete transactions executed than insert tr - not. its just freeze... – dummy Dec 1 '14 at 12:43
1

So made a workaround. I noticed that insert example

<wfs:Transaction service="WFS" version="1.0.0"
  xmlns:wfs="http://www.opengis.net/wfs"
  xmlns:topp="http://www.openplans.org/topp"
  xmlns:gml="http://www.opengis.net/gml"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.0.0/WFS-transaction.xsd http://www.openplans.org/topp http://localhost:8080/geoserver/wfs/DescribeFeatureType?typename=topp:tasmania_roads">
  <wfs:Insert>
    <topp:tasmania_roads>
      <topp:the_geom>
        <gml:MultiLineString srsName="http://www.opengis.net/gml/srs/epsg.xml#4326">
          <gml:lineStringMember>
            <gml:LineString>
              <gml:coordinates decimal="." cs="," ts=" ">
494475.71056415,5433016.8189323 494982.70115662,5435041.95096618
              </gml:coordinates>
            </gml:LineString>
          </gml:lineStringMember>
        </gml:MultiLineString>
      </topp:the_geom>
      <topp:TYPE>alley</topp:TYPE>
    </topp:tasmania_roads>
  </wfs:Insert>
</wfs:Transaction>

have this anmespace declaration

xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.0.0/WFS-transaction.xsd http://www.openplans.org/topp http://localhost:8080/geoserver/wfs/DescribeFeatureType?typename=topp:tasmania_roads"

I delete it and transaction works fine.

  • Welcome to GIS SE! I notice that you have tried to ask a supplementary question in the area reserved for direct answers to your question. Consequently, I will delete that and recommend that you research/ask it separately as a new question. – PolyGeo Dec 2 '14 at 5:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.