4

I am trying to change the CRS of one shapefile that is originally in NAD27 to WGS84 in Qgis 2.6enter image description here. When I proceed to make the change, I still continue to see the file in UTM coordinates... I've tried to save the file as a new one with the and change it at the "set layer CRS" option... Do you know another alternative?

  • Have you set the project properties to match the WGS84 layer? If not it's projecting on-the-fly to NAD27 (I assume) or what you had it as before. – Michael Stimson Dec 2 '14 at 2:47
2

NAD27 EPSG:4267 and WGS84 EPSG:4326 are both CRS with lat/lon degrees.

The extent of your layer is in a projected CRS, but the projection information does not reflect that.

The most common pitfall in QGIS is to use Set CRS for Layer, which changes the CRS, but not the coordinates. You have to switch that back, or delete the layer and reload the original, then Save As... to another filename and CRS.

Try Settings -> Options CRS tab; Prompt for CRS for new layers to avoid automatic assignment of wrong default CRS, if the data does not come with projectiuon information.

UTM coordinates can be defined on either NAD27 or WGS84, so you have to be sure which one your data has (unless it is some state plane coordinate system or else).

  • 1
    take in to account this: gis.stackexchange.com/questions/123069/… – Gerardo Jimenez Dec 2 '14 at 16:42
  • @GerardoJimenez QGIS uses internally by default the ntv2 transformation from NAD27 to WGS84. That should be very exact. – AndreJ Dec 2 '14 at 17:14
  • Addendum: ntv2 is used for Canada, and NADCON for the United States. Mexico is partially outside the exact datum grid transformation. – AndreJ Dec 12 '14 at 4:52
3

I think there may be a bug in QGIS save as. This is from QGIS 2.6.0 (Brighton):

The easiest way to export a shapefile to a new coordinate system in QGIS is to right click on the shapefile and select 'save as' then in the dialog select Selected CRS which pops up a dialog and then select the 'to' CRS (in your case WGS84):

enter image description here

Using the method employed in previous versions: set project CRS then export using the project CRS the CRS does not change:

enter image description here

This is probably a new bug in QGIS; this method worked in previous versions (QGIS 2.0.1 Dufour).

After saving the new layer don't forget to change the CRS of the project or it will continue to use a different CRS: Right click on layer then select 'Set Project CRS from Layer' or in project properties from the list of available options.

  • 1
    I never trusted the Project CRS option, and always use the Selected CRS one with the Change button to get the right projection. – AndreJ Dec 2 '14 at 4:50
  • 2
    It works that way in ArcMap @AndreJ. It's good to have that option working - the two most likely choices are 1. Match the existing data and 2. Match the project/map. That way if you're doing a few you don't have to think too much and limits the potential of hitting the next/previous CRS in the list. – Michael Stimson Dec 2 '14 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.