2

Esri persuaded us to upgrade to SP2 and now we cannot use the code we have, as it doesn't work.

According to the download material, NIM063853 is when AggregatePoints doesn't create the derived table.

This worked in SP1, now doesn't in SP2. Has anyone else experienced this? Any workarounds?

  • What's your code? How does it fail when run under SP2? – Philip Jul 21 '11 at 20:24
  • It's not that it fails, it just buiods and builds the memory useage, so that when the first item gets processed in 4 seconds, the 20th takes 18 secs, the 40th around 32 seconds and the 70th over a minute. All the same operations on roughly similar sized objects... – Hairy Jul 22 '11 at 6:34
1

Potential Workaround:

ET GeoWizards LT will do this functionality for free.

http://arcscripts.esri.com/details.asp?dbid=11903

'All 28 functions included are fully functional with no restrictions whatsoever'

  • I have tried, but my points are arranged over a very large area and it doesn't handle it; we have the full version, and it just can't take the amount of points (up to 300k), or their spread. – Hairy Jul 20 '11 at 14:33
  • Can you use the 'Tiled processing of large datasets' with Model Builder +GeoWizard Tools Scripts? - help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//… – Mapperz Jul 20 '11 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.