2

I have successfully built a Web server using ubuntu 14.04, Qgis 2.6, with the plug-in lizmap as a local server. I have several polygons being displayed and some WMS raster's from NOAA's WMS. I know that this is possible using NOAA's service because it is stated here that "LayerInfo web service provides access to additional useful layer information" and the layer information query is provided (examples of the correct html format are on this link).

In my web browser I can Identify attribute data of the features that I have created (points, polygons, lines).

However I am unable to identify the raster attribute data. All I want to be able to do is click on the raster and have the legend appear, it does not need to be a pixel specific legend the image provided by NOAA is sufficient (see below image example).

I was unable to get this to work on my WMS layer so as a test I made a custom pop up of this legend and assigned it to my own data and the legend appeared...Why can I not do this with the WMS raster layer and is it possible? If not what is the work around?

http://nowcoast.noaa.gov/LayerInfo?layer=EOFS_RAS_SPD_NCST&data=legend http://nowcoast.noaa.gov/LayerInfo?layer=RAS_RIDGE_NEXRAD&data=legend

2

Add the hyperlink to the legend in the "Link" box in the Lizmap Plug in. in info button will appear next to the layer and clicking on it will bring up the legend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.