Sorry if this is a very beginner question, but I can't seem to find an answer online by searching.

Is there a way to increase the size of the "map units"?

I'm trying to draw lines attached to my map so that when I scale it, the lines change size relative to the underlying map. In the styles dialogue I'm selecting map units, but the line doesn't even show up until I set it to 10000—and even then it's too thin for what I need.

enter image description here

Is there a way to change the scale of these "units" so that I can make them be more useful for the map I'm trying to make? I've tried changing Project Properties > General > Canvas Units to nautical miles, but that didn't make any difference. I've also tried changing my CRS (to no effect), but I'd like to stay with EPSG:3857 if possible.


It appears that if I use EPSG:4326 the the line works exactly as expected, but because I have several more complicated elements such as georeferenced rasters and 47 other layers, I need the to use the Google Coordinate system (also so OpenLayers works. Is there no way to draw lines on an OpenLayers map?

Here's a few screenshots of my settings:

enter image description here

enter image description here

enter image description here

Changing the CRS here in the style settings just makes the line disappear completely:

enter image description here

  • Could you add screenshots of the style settings? Something is odd here.
    – underdark
    Dec 3, 2014 at 21:42
  • @underdark Thanks! I added screenshots—I don't know what might help so I did a bunch.
    – Ryan
    Dec 3, 2014 at 21:51
  • what happens if you write 10e7 does that give 10 million?
    – Ian Turton
    Dec 4, 2014 at 9:11

2 Answers 2


Edit: Seems I misunderstood the question. Leaving this answer if someone finds it useful for something else.

Under Style, the setting "Map units" is usually in meters (or degrees if you're in an unprojected coordinate system like WGS84,) and you use that when you want the line to be exactly the same size in relation to the geography regardless of zoom level (a 10 meter wide line will be very large if you're zoomed all the way in, and not even visible at a very low zoom level.)

Change the unit under Style to millimeters, that way it will be consistent regardless of your zoom level.

  • I understand that difference, I want these lines to reference the size of the geometry on the map itself. I am using millimeters for other parts of the document, so that the exported pdf integrates well into the rest of the document. These lines are an illustration though, so they have to stay the same thickness.
    – Ryan
    Dec 4, 2014 at 8:40

It sounds like it would be more practical to make a polygon if you need a very wide, geographically consistent "ribbon."

I suggest that you buffer your original line and style that instead. If you play around with styles you should be able to hide the fact that it's a polygon rather than a line.

  • I'm using an attribute table to modify the thickness of the line precisely to match some data I have, so that's why I went with lines over polygons. Is there any way to do that with a polygon? Sorry, I'm completely new to this.
    – Ryan
    Dec 4, 2014 at 8:49
  • Yes, if you go into the menu Vector and under the sub menu Geoprocessing tools (I think it's called that in English, it's the one with a little cog as the icon,) and then choose buffer, you can specify the length. So if the front was 2 km wide, you put 1km in there. You'll probably get rounded edges though, and that may or may not be something you want to edit afterwards.
    – hexamon
    Dec 4, 2014 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.