6

I am using ENVI 5.1 on Windows 8. I am trying to open a MOD17A3 (MODIS Net Primary Productivity standard product - L4) .hdf file which I downloaded from the USGS website. I am still a beginner at ENVI, IDL, Remote Sensing, and GIS.

My problem is when I try to use the ENVI GUI and open the file.

When I open the .hdf file as a EOS>MODIS file, it appears properly georeferenced when overlaid with other vector layer that I am using, BUT it does not show the data for each pixel. What I mean is, the shapes of the landmasses are present, but they are all in black, not showing any NPP data which should have made the pixels appear in varying shades of grey.

When I open the .hdf file as Generic Format>HDF4, ENVI asks me to select which datasets in the .hdf file I should open, and I select NPP. The values of each pixel are displayed, such that they appear in varying shades of grey, BUT they don't seem to be properly georeferenced since they don't align with other georeferenced layers. The map has shrunk, but is in the same general location as the other layers.

It might be possible to use the IDL controls to solve this problem but I wouldn't have any idea where to start.

  • 1
    Have you been to their ENVI website ? – PROBERT Dec 7 '14 at 17:28
  • MOD17A3 is very easy with Modis Conversion Toolkit github.com/dawhite/MCTK I have the script for this solution, tell me what TILE modis do you need working Regards??? – Sigologo Jan 14 '15 at 14:05
0

Check the "stretch" on the original Modis file. The data may actually be in the pixel but the default stretch may make them appear as black.

Stretch toolbar

Also, to check and see if the data is actually in the image, use the crosshair tool.

Arrows point to crosshair tool and pixel data value

You might save yourself some time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.