1

Trying to get a tileserver running on Ubuntu 14.04 with TileStache and Apache.

No problem running the TileStache development server (tilestache-server.py) or the uWSGI example from the API docs:

uwsgi --http :8080 --eval 'import TileStache; application = TileStache.WSGITileServer("/etc/TileStache/tilestache.cfg")'

However, I can't get it to serve tiles with mod_wsgi through Apache (2.4.7). Followed the instructions here: https://github.com/TileStache/TileStache/issues/67:

Created wsgi file (/var/www/tilestache/tilestache.wsgi, owned by Apache with 0750 permissions) containing:

import os, TileStache
application = TileStache.WSGITileServer('/etc/TileStache/tilestache.cfg') 

Following those instructions, added:

WSGIScriptAlias /tilestache /var/www/tilestache/tilestache.wsgi

To my Apache config. Navigating to that alias on any of the defined virtualhosts returns a 403 - Forbidden.

I've also tried replacing that line with the following, but returns the same 403:

WSGIDaemonProcess tilestache
WSGIProcessGroup tilestache
WSGISocketPrefix /var/run/wsgi
WSGIScriptAlias /tilestache /var/www/tilestache/tilestache.wsgi

I've also tried moving those lines inside of a virtualhost, with the same result.

Note: I've changed the tilestache.cfg to use the test/simple cache (not actually caching anything).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.