1

Im using QGIS 2.6.1 Brighton on an IMac with OSX 10.8.5. QGIS 1.8 worked on the same machine, as did QGIS 2.0. AFter installing 2.6.0 and then 2.6.1 I opened a file I'd used before and several queries were done. The attribute table had the selected items, but they did not appear on the screen as they had in the earlier version. When I tried to add the saved file to the map, it did it once and never again. The error message was that the shp file was not a valid data source. The shapefile does not appear to be saved. What am I missing?

  • Sorry, I can't follow the problem description. Please clarify what you are trying to achieve and what the problem is. – underdark Dec 8 '14 at 9:31
  • Use the Save As... option on your original shapefile and save it with another name. Then try to see if you can edit and save the new shapefile successfully. – Joseph Dec 8 '14 at 15:56
  • I tried that, it appeared until I did the query and then it disappeared. I've unselected all of the selected items, nothing appears. – Lyle Browning Dec 8 '14 at 16:10
1

Upon further experimentation, it appears that upgrading from earlier saved files into Brighton was the cause of the problem. I have regenerated shapefiles, imported them, joined them and queried them. The non-matches disappear from the screen and I am able to save the resulting layer and have it appear on screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.