1

I'm trying to vectorize a raster image and when I'm running polygonize within QGIS 2.6.1. I'm getting the following message:

Traceback (most recent call last): File "C:\PROGRA~1\QGISBR~1\bin\gdal_polygonize.py", line 36, in import gdal, ogr, osr ImportError: No module named gdal

I know that gdal is installed. I don't know what to do! Need help!

  • Have you tried unchecking GdalTools from the Manage and Install Plugins... menu > restart QGIS > re-check GdalTools from menu? – Joseph Dec 8 '14 at 11:12
  • Did that. Restarted 2 times. The same error... – user26541 Dec 8 '14 at 11:35
  • Perhaps uninstall and then reinstall QGIS might solve the problem? – Joseph Dec 8 '14 at 12:37
  • I've installed a new copy of Qgis and still the problem persists. – user26541 Dec 8 '14 at 15:37
  • If you haven't done so, try running via Raster > Conversion > Polygonize or via the Processing Toolbox. Otherwise, I'm out of ideas and hopefully others can advise :) – Joseph Dec 8 '14 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.