1

I tried to install QConsolidate by placing the plugin folder ("qconsolidate-master") in: c:\users\.qgis2\python\plugins\

but received an error "Couldn't load plugin qconsolidate-master due an error when calling its classFactory() method" when starting QGIS. I am using QGIS 2.4.0-Chugiak.

Is there an incompatibility issue?

1

Well, I found the QConsolidate plugin in the Plugin Manager list after enabling searching for experimental plugins under "Settings". Plugin Manager got it from the repository and installed successfully.

| improve this answer | |
0

Please use the plugin installer to install packages it will take care of everything. If you do need to manual install you will need to remove the - from the file name:

qconsolidate

| improve this answer | |
  • Thank you for the suggestion, but it did not solve the problem. Also, QConsolidate does not appear in the Plugin list, and it is labeled as "Experimental". It appears there is a module missing from the code: In the Plugins menu I see an error "No module named ui_qconsolidatedialogbase". – LeaningCactus Dec 9 '14 at 15:18
  • Also, the code repository is supposedly "github.com/alexbruy/qconsolidate". When I add this address as a new plugin repository in QGIS, I receive error "Status code: 301 moved permanently". So I can't seem to install this plugin neither manually nor with the plugin installer. – LeaningCactus Dec 9 '14 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.