I have a problem with LAStools in QGIS 2.6.1. I have never used QGIS to process LiDAR data before.

I downloaded LAStools yesterday from the rapidlasso GmbH website. I unzipped the “lastools.zip” file into my osgeo folder (C:\OSGeo4W64\LAStools) and followed the instructions for activating LAStools and specifying the folder location. LAStools appears correctly in my Processing Toolbox in QGIS.

Then, I downloaded a LiDAR tile from the National Land Survey of Finland as a .laz file. I tried to use lasground to view this data, and followed the instructions on the rapidlasso GmbH website (see screengrab). However, I get this message in my log:

Algorithm lasground starting...global name 'os' is not defined See log for more details

Am I missing some dependency from my library?

enter image description here

  • QGIS 2.6 should already come with LiDAR tools installed, you just have to set the provider for the lastools folder within your QGIS directory. For example, mine is C:\Program Files\QGIS Brighton\apps\qgis\python\plugins\processing\algs\lidar\lastools.
    – Joseph
    Commented Dec 10, 2014 at 10:41
  • Thanks Joseph. You were right about the LiDAR tools. I found them in the same folder location. I changed the folder location for the LAStools folder in Processing>Options>Providers>Tools for LiDAR data. I'm afraid I'm getting the same message though.
    – Richard
    Commented Dec 10, 2014 at 11:05
  • 1
    Hmm seems a few other people also have this problem (groups.google.com/forum/#!topic/lastools/ktyrnfDjrQ4). I never used LiDAR so cannot provide much assistance but when I try to run it on a sample .las file, nothing happens. Hopefully others will advise.
    – Joseph
    Commented Dec 10, 2014 at 11:21
  • Thanks Andre. I looked into that and, according to the rapidlasso GmbH website instructions, LAStools should be able to open .laz files. I'm no expert but I assume LAStools incorporates LASzip. Now I'm just wondering whether I'm missing something from the LAStools folder for decompressing .laz.
    – Richard
    Commented Dec 10, 2014 at 17:53
  • 1
    Thanks again Andre. I took your advice and tried to open a .las file downloaded from the Pennsylvania Spatial Data site (pamap.pasda.psu.edu/pamap_lidar/cycle1/LAS/North/2006/20000000). No joy I'm afraid. Still the same message.
    – Richard
    Commented Dec 13, 2014 at 21:41

3 Answers 3


My problem was that there was a space in the path to the .las file I was using.

  • 1
    We want longer answers. If you had the same problem consider expanding the answer. perhaps even screen shots showing both the broken and the cure.
    – Brad Nesom
    Commented Feb 17, 2015 at 14:48

I followed the instructions contained within the README.txt file of the lastools newest version, a zip file downloadable from this link: http://lastools.org/download/lastools.zip. Extract the zip file to any folder without spaces in the path. Open the QGIS_toolbox folder where you find the README.txt file. Open this file and follow the instructions from the line number 24. I have QGIS 2.6.1 installed on Window 7 and lastools work well. For now I tried only the lasview algorithm.


I have also been headbanging and have at least a partial solution. On a Mac, Go to Processing and then Options but DO NOT CLICK on activate. Click (or perhaps right click) on the white space on the right side of the folder icon, hit the right 3 dot button on the right side, then go to applications and select QGIS.

THEN hit the activate button.

I can then get a LASTools project to open with an input menu that I have not yet tried, but those steps do away with the "LASTools folder is not configured" that one gets otherwise. I either clicked or right clicked on the LASTools project in the window to activate the initiation window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.