I have a very large model made in Google Sketchup v 7.1. I would like to export this to a Multipatch featureclass, so that I can view it in ArcScene, with other 3D data.
I have tried several things, but none of them have worked. I have tried the following things:

  1. Used the Sketchup Plugin for ArcGIS; For this I have saved the model as a sketchup 6 model, and on a machine which has Sketchup Pro 6 & ArcGIS 9.2, used the export as ESRI Multipatch. This works for small and simple models, but fails on my Large Model.

  2. Exported the Model as KMZ, and then tried to use the QuickImport using the InterOp Extension of ArcGIS.

  3. Exported the Sketchup 6 Model as Google Earth 4 KMZ. Then, I tried to use the QuickImport using the InterOp Extension of ArcGIS. This does import the KMZ to Multipatch, but it does not fall where I expect it to fall. Its size is very large as well (when compared to actual or expected size).

Has anyone else managed to do something like this?

5 Answers 5


If you can upgrade your version of Data Interop then you will find that there is now direct SketchUp support included. That would at least eliminate the export to KML step.

Also the 3D support with this extension is improving all the time, so upgrading may eliminate the other issues you are experiencing. The way to test would be to install the evaluation version of FME 2010 (the engine behind that extension) and try it using that. If it works then you know if an upgrade will help or not.

Disclaimer: I am the Senior Product Specialist at Safe Software Inc.


After fighting with it for a couple of days, I have found this:

  • You can export a v6 SKP directly to Multipatch, using the InterOperability Extension.
  • You can export a v6 SKP directly to Multipatch, using the 'Import 3D Files'Tool from the 3D Analysis Toolbox.

The Main Issue then is, is that these Multipatches do not fall at the correct Place. On digging further I found that the v6 SKP itself is not geo-referenced. The loss of spatial reference happens when you save the skp in Sketchup 7 to a v6 skp file. And the above two methods don't work with a v7 Sketchup file.

So now you have a multupatch, but at the wrong place and of the wrong size. If it is small enough, you can move it, using the 3D editing Tools in ArcGIS 10. But If you have a large model (like I did) then ArcGIS just freezes when you try to move it.

Hence I ended up using some ArcObjects code to move the multipatch and scale and rotate it accordingly.


After some tries, this is the way I found for models which I built. I started the models still with the SU plugin in ArcGIS9.3, which means they have a proper Georeference AttributeDictionary. Now, how to place them in ArcGIS10:

Export a file, let's call it "Model.DAE", (Collada DAE, not SKP version 6) from SU8. In ArcCatalog10, create a new FeatureSet in your geodatabase (I call it "3D_Models"), using your original coordinate system (I guess you should use UTM if you started your modelling inside Sketchup and georeferenced it via its Google Earth link), then use the "Import 3D Files" from the Toolbox to import the file "Model.DAE" into a new Multipatch FeatureClass (let's call it "Model") inside 3D_Models. Now your model is part of the FeatureSet, inheriting its coordinate frame. Typically, it now is badly located. In SU, read the value of ModelTranslationX, ModelTranslationY from the model's GeoReference AttributeDictionary. These are offsets in inches (!). Convert those values to metres, and "Edit 3D features", Select your model Multipatch feature, and "Move..." by these amounts. If all worked well, you should have a perfect match!


Some good tips in ArcUser January - March 2007

"Urban Modeling with ArcGIS 3D Analyst and SketchUp"


I have use Sketchup and have used PhotoShop CS Extended for very large Collada DAE/KMZ files. (Still some issues)


Did you try sketchup pro to collada then import to ArcScene (version 10) This should now be an out-of-the-box functionality.

  • A good tip for ArcGIS 10.
    – Mapperz
    Aug 23, 2010 at 2:19
  • I tried that, and it works even at 9.3, but only for small models, not the large one that I have. Aug 25, 2010 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.