6

I've been trying to split a large land use shapefile using a set of study area polygons as the split feature, but when the function finally finishes running (the land use dataset is quite large), all of the shapefiles created by the split are empty. We also tried using another computer, but found the same result, both using ArcGIS 10 with SP2.

Is there any reason why this is the case? Are there any alternate methodologies which would achieve a similar result to split?

Edit: To be more specific: the split field is the FID in text form and we didn't run into any errors relating to the input fields. The study area polygons completely contain the land use.

6
  • This tool has some usage parameters that need to be followed, have you checked all of these? help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Split/…
    – artwork21
    Commented Jul 26, 2011 at 16:17
  • You'll have to be a bit more specific about what parameters you used when performing the tool for us to troubleshoot effectively. What are you using as your split field, and what is its data type? Is the split field unique? Are you certain that your split polygons are spatially coincident with your input shapefile?
    – Nathanus
    Commented Jul 26, 2011 at 16:34
  • I've checked the parameters and your suggestions but the criteria are met.
    – Emily
    Commented Jul 26, 2011 at 16:55
  • Use File Geodatabase rather than shapefile - much more functionality is supported with Geodatabases.
    – Mapperz
    Commented Jul 26, 2011 at 17:07
  • I'm having the same issue. I'm using a point feature class (technically shapefile) as the input, and a polygon feature class (technically shapefile) as the split. Empty output when I point at geodatabase (w/ appropriate characters i.e. letters) or shapefile (w/ number characters), and when I use the whole feature class (49,000 points) or a small subsample (a few hundred). Same issue. Confounding. Projection is not an issue. Empty feature classes is the result. I've performed the split function on other feature classes many times before, often using the input as the split feature... Is it an is
    – user3780
    Commented Jul 27, 2011 at 0:15

4 Answers 4

5

Split tools has an error in ArcGIS 10 SP2. The tool makes the split, but leaves all features empty. Esri was registered this error and recommends for now, if you want use the split tool, downgrade ArcGIS to SP1. I suggest you visit this link http://resources.arcgis.com/es/gallery/file/geoprocessing/details?entryID=6C5D9A77-1422-2418-7F6C-01564409B1AF , where you found an alternative split tool for ArcGIS 10 SP2, this has only one detail, when process the split generates all output features, including the features without features, after you execute this tool must check the features and erase the ones that empty.

2
  • Welcome to our site, @Diego! Thank you for your informative reply.
    – whuber
    Commented Aug 3, 2011 at 14:59
  • Going to try uninstalling SP2 and will report back but this seems likely that it is the error.
    – Emily
    Commented Aug 3, 2011 at 21:19
3

Try converting the shapefile to a file or personal geodatabase, then perform the split and save the results to a geodatabase.

In my experience with ArcGIS and vector analysis, shapefiles can be buggy about large feature sets with numerous nodes/vertices and shared edges (e.g. many landuse datasets).

5
  • I'm having a small problem where it returns now a "000361 : The name starts with an invalid character" error. How would I find out where this is?
    – Emily
    Commented Jul 26, 2011 at 18:33
  • The field name in the geodatabase starts with an invalid character.
    – user3461
    Commented Jul 26, 2011 at 18:48
  • I'm just not certain where to find it, I've looked at the feature classes within and the only character is an underscore... is there anywhere which has an invalid character list?
    – Emily
    Commented Jul 26, 2011 at 19:37
  • "is there anywhere which has an invalid character list? " - This would probably be best to ask as a new question on the site, as it is independent of the original question and answer.
    – user3461
    Commented Jul 27, 2011 at 15:23
  • 1
    You should look at the following KB article: support.esri.com/en/knowledgebase/techarticles/detail/31122 Commented Jul 27, 2011 at 17:11
1

When you run your split you could set the tolerance to be very large to see if that works (it will run quicker for certain).

1

I wrote this script to perform the same functionality as the split tool. If you're splitting a large feature class you may want to change the copy features for something else. The feature class I split was small.

import arcpy, os
arcpy.env.workspace = ""
list = [] #Input the values you would normally split by or populate this using another method
input = file #change this to the FC you're splitting
layer = input+"_lyr"
arcpy.management.MakeFeatureLayer(input,layer)
for item in list:
    query = "" #add query statement
    arcpy.management.SelectLayerByAttribute(layer,"NEW_SELECTION",query)
    output = "" #add base output file name
    arcpy.management.CopyFeatures(layer,output,"#","#","#","#")
arcpy.management.Delete(layer)

Feel free to take this and improve it. I'm still learning

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.