4

enter image description here

This may be quite basic but can't figure it out.

I have a problem when adding a description to a layer (right click layer -> properties -> general: description). When I update the description, then remove the shp and add it again, the description isn't updated. How should I do this to have the updated description saved at the layer's properties? I tried several times with shapefiles and layer files, and it is updated in layer-file properties, but not in shapefile's. I would need the description of a shapefile to be updated because I'm sending shapefiles to another person.

I'm using ArcGIS 10.1 for Desktop.

2

You mention ArcMap. The description you are providing there is only maintained within the mxd or layer file. If you want to update the meta data about the data, use the Description tab in ArcCatalog. This updates the meta data and saves it to an associated xml file.

  • 1
    Thanks Neil, I tried this but for some reason I seem not to be able to write anything in that description tab in Arc Catalog in any of my layers or mxds, although I click "Edit". It seems to me I'm doing it the same way as in ArcGIS help, but I'm not able to edit the description. – Linda Dec 16 '14 at 7:33
1

I agree with @Neil Ayres and urge you to fill in the metadata of the dataset as that will follow the data if you use ArcCatalog to make a copy of the dataset. The layer properties as you described above is for a FeatureLayer and any information entered there exists only in the MXD or the LayerFile if you create one. Entering information into the metadata does not translate to seeing it in the Layer properties dialog. You will only see it in what ESRI are confusing calling Item Description. It's very good practise to document who/what/when/why/limitations in the metadata. It gives weight to your data and is usually the first place any professional GIS user will go to and is generally disappointed when they they don't find it!

  • I agree with this; metadata is very important when sharing shapefiles. The issue now is that I can't add it to the item description in ArcCatalog (it doesn't allow me to write anything, although I click "edit"). – Linda Dec 16 '14 at 13:34
  • So you are in ArcCatalog, you are on the description tab looking at the default metadata, you click edit. Does the screen not change to allow you to edit the text? If so are you pressing save to commit the changes? I suggest you upload an image showing at what stage you are at? – Hornbydd Dec 16 '14 at 14:46
  • I'm at item description, and clicking "edit" gives me an empty space with possibilities "save" and "exit". However I can't write anything there. – Linda Dec 17 '14 at 13:02
  • The picture is attached to my question now. – Linda Dec 17 '14 at 13:10
  • OK that is odd behaviour, ArcMap/ArcCatalog should not be doing that. Try creating a new dataset, anything, then see if you can edit its metadata? If that works it would suggest the metadata data for your other dataset is corrupt. If your new dataset has the same problem then it would suggest that ArcGIS is corrupt or it's a Windows update that has upset things. Have you searched here for known issues? – Hornbydd Dec 17 '14 at 13:36
-1
  1. Go to the Customize tab.
  2. Select ArcCatalog options.
  3. Select Metadata options.
  4. Select FGDC.

It should then work

  • Welcome to GIS SE! As a new user be sure to take the Tour to learn about our focussed Q&A format. – PolyGeo Oct 9 '17 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.