4

I need to install QGIS on my mac with 10.10 Yosemite, I have already installed: - SQLite3_Framework-3.8.7.3 - GDAL_Framework-1.11.1-2 - GSL_Framework-1.16-1 - NumPy-1.8.0-1

but when I launch QGIS.pkg it says it requires SQlite3 framework. Please help me

  • Have you done a clean install (including removing old QGIS and emptying the trash)? – Simbamangu Dec 16 '14 at 14:14
  • I never had QGIS or other similar file etc.. is all clean – Mr Prince Dec 17 '14 at 1:05
  • Try to uninstall SQLite then reinstall GDAL then QGIS. – Simbamangu Dec 17 '14 at 5:28
  • This is definitely a better topic for the OSGeo user forums. – Simbamangu Dec 17 '14 at 5:29
  • Nothing to do... it says it needs the sqlte3.framework but I have installed it twice and it is in the folder /Library/Frameworks/ – user43265 Dec 22 '14 at 19:30
2

I had the same problem. You need to install the SQLite3 framework available here: http://www.kyngchaos.com/software/frameworks I'm guessing that the version of the framework you have is old or that it's not symlinked properly but the installer available on kyngchaos website should fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.