0

I was used to develop qgis2leaf on a Ubuntu machine and after each change on the PyQT dialog I've used "make" in the terminal to "compile" the GUI. How does this work on a Windows machine?

6
  • If you installed QGIS with OSGeo4W, you will have also a OSGEO Shell, that is a normale cmd.exe with all OSGEO path and env correctly configured. Opening the OSGEO shell, go to dir of you plugin and type make! make command should be installed with pyuic and pyrcc compilers Commented Dec 16, 2014 at 19:54
  • tried! got the response: make: pyuic4: Command not found.
    – Riccardo
    Commented Dec 16, 2014 at 20:03
  • the pyuic4 command is shipped with the qt installation according to this: stackoverflow.com/questions/18429452/convert-pyqt-ui-to-python
    – Riccardo
    Commented Dec 16, 2014 at 20:09
  • 1
    hmmm... how did you installed QGIS with osgeo4w? it should install all this staff as "dependencies"... pyuic4 should belogs to PyQT4 package. Is it installed in your OSGeo4W environment? Commented Dec 17, 2014 at 9:47
  • No, I used the standalone installer. Yet this has the osgeo shell as well but "make" was not working. I now work on Ubuntu in a VirtualBox. So I am not dependend on an answer anymore but thanks!
    – Riccardo
    Commented Dec 17, 2014 at 14:10

1 Answer 1

1

I've ran in the same problem with the current QGIS 2.6.1 by just typing make I had the same error again.Now I've searched for the pyuic4.bat file and it was located correctly. SO I just used the absolute path in the OSGEO4W Shell:

C:\Users\ricckli\.qgis2\python\plugins\qgis2leaf>make
pyuic4 -o ui_qgis2leaf.py ui_qgis2leaf.ui
make: pyuic4: Command not found
make: *** [ui_qgis2leaf.py] Error 127

This one was working without a problem:

C:\Users\ricckli\.qgis2\python\plugins\qgis2leaf>C:\OSGeo4W64\bin\pyuic4 -o ui_q
gis2leaf.py ui_qgis2leaf.ui

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.