I am importing an Excel table with X/Y coordinates to plot on a map (point data).

The original Excel table has a header row as its top row..The row is 'frozen' in Excel.

When I import the table and view it in ArcMap (10), the header row of the original Excel sheet is gone, and the first feature row is now the header row in ArcMap.

How can I avoid this?

  • 3
    I have always had trouble with Arcgis and Excel in general. One thing I have started doing is to first import the tables into a geodatabase. this seems to put the data in a nice format for Arcmap and allows you to dictate the field types. Dec 17, 2014 at 18:30
  • ncie thought, didn't work though...
    – JasonBK
    Dec 17, 2014 at 21:01
  • 1
    I am not able to replicate this issue with ArcGIS Desktop 10.0 SP4. A 'frozen' header field displays correctly when dragging and dropping the Sheet into map, exporting table to a feature class, and/or Creating Feature Class From XY Table.
    – Adam
    Dec 17, 2014 at 21:04
  • I've tried all those thing as well, with the same results..I havn't seen this before...I also checked for illegal characters etc in field names but they all look fine...
    – JasonBK
    Dec 17, 2014 at 21:09
  • 1
    Try exporting the Excel to a csv file first, or dbf if the field names are short enough.
    – recurvata
    Dec 17, 2014 at 21:29

5 Answers 5


I had the same problem (Arcmap would not import my csv file with headers, instead it would show Field1, Field2, Field3 etc). When I examined the file headers in Excel, I found...decimals numbers, spaces, percent signs etc. After replacing all of that with underscores or text, I had no problems. I dragged the .csv file into arcmap, opened the attribute table and all the headers were displayed perfectly.

  • 4
    Marissa is correct. If you have columns in your CSV or Excel file that are numbers, they will read as data rather than field names in ArcMap. You can rename them in Excel, and that should work (e.g. if you have 2016, you could rename as year_2016). Apr 18, 2017 at 19:57
  • To state Marissa's answer precisely: Best is a csv-file (not txt, dat or any other). Renaming a txt- or any other file to a csv-file by changing the file-suffix will do it.
    – stonebe
    Mar 2, 2021 at 8:51
  • I ran into this issue as well. The solution didn't work for me at first. This sometimes happens because of the schema.ini file, but even after deleting it, ArcGIS wouldn't recognize the correct header. I finally had to restart ArcGIS Pro and then the header was handled correctly.
    – nrp1000
    Aug 8, 2023 at 14:18

For me, it was because one of my headers was just a 0. ArcGis doesn't like it when a header begins with a number. I just added an N in front of the 0 and it imported fine.


If your file is an .xls or .xlsx file these should open correctly in ArcMap. Clearly this isn't happening though, but my experience of using Excel is that it simply stuffs up csv exporting and the resulting file isn't usable.

Does opening the .xls or .xlsx file in LibreOffice Calc then saving as a text csv (with commas as a field separator) and importing into ArcMAP do this correctly?

This is based on my own experience of using Excel and the solution to this similar question: ArcGIS 10.2.1 is not recognising my CSV file headings


I just ran into issues with Arc moving headers around but leaving the data in place below the headers when importing csv census data.

I got around the issue by saving the table as a tab delimited .txt file instead.


I found that just formating the first line as text worked well. I also had to format the numbers as numbers and use points as decimal separator instead of commas in excel to be able to classify the data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.