7

I have a major problem with the OpenLayers plugin. The maps of the plugin won't zoom to the right scale, or they just simply crash. I never had these problems in the old QGIS versions. This way, I can't work with this version of QGIS. Does anyone know how to fix this?

The shape file opens on the right place on the OpenLayers map. However when zooming, the Google map is not in line with the shapefile (the added picture shows this in extreme, the lines should show up somewhere in the Netherlands).

OpenStreetMap don't seem to show the zoom problem. However, check the OpenStreetMap layer on and off, makes this layer to crash and show a white screen.

Where can I find a download of an older version of QGIS? E.g. QGIS 2.4 (64 bit)?

zoom problem with open layers plugin

  • 1
    Do you have most recent version of OpenLayers plugin? I had a similar problem. Another way I fixed this when it was crashing, was to make sure I loaded a layer with ESPG:4326 - this seemed to help the plugin figure out the bounds of what I was looking at. – djq Dec 19 '14 at 14:24
  • 1
    You can find all old QGIS versions here: qgis.org/downloads, but the current version of the openlayers plugin will not work with older versions (at least not with 2.2 and older). – AndreJ Dec 19 '14 at 17:59
  • Yes djq, I have updated to the most recent version of the Openlayers plugin. My layer is indeed not in ESPG:4326, but in EPSG:28992 instead. However in a old version of Qgis 1.8, this was not a problem in the open layer plugin. I read more problems/ questions with Qgis 2.6 and the open layer plugin, especially with zooming issues... I think it is strange that in old versions there were no problems with this and now there are.. – wouter Dec 20 '14 at 8:43
  • Thanks AndreJ, I might go back to an old version. At the moment I can work with the Bing Maps Aerial, however I keep having problems, even with Bing, when zooming in. It doesn't show the map after a certain level of zoom. It is not as annoying as the google and open street maps thought. The Bing maps work at least, the rest doesn't especially the google map is really bad. – wouter Dec 20 '14 at 8:46
  • see: gis.stackexchange.com/questions/127394/… – John Dec 27 '14 at 14:38
4

I have noticed that the open layers instance of google earth is very sketchy from time to time. You can try working with Bing Maps Aerial imagery, this works a bit more reliable on my side.

This is not an answer to your question, but it might be something worth to look into.

Goog luck!

|improve this answer|||||
  • Hi Max, Thanks! Bing Maps Aerial does work a lot better! However it remains strange that I don't have these plugin problems in the old versions of Qgis? But for now, I can go on with these Bing maps! – wouter Dec 19 '14 at 12:55
4

I found a 'solution' to get google maps to show up correctly in QGIS. It is probably not perfect, but it works quite well.

Here is what you need to do:

  1. Save the XML file located here anywhere on your computer (right click and save as on the link). You can edit the file to use any version of google maps.
  2. Once you have the file on your system, go to QGIS -> LayerAdd raster layer
  3. Search and add the XML file as a raster layer to your project

You should now have google maps as a basemap.

I hope this helps!

EDIT: For people that find this solution slow or would rather just use the openlayers plugin, this might be a nice solution for you.

|improve this answer|||||
  • In the 64 bit version of Valmiera this solution just gives a pure turquoise background with no map at all. – shawty Dec 30 '14 at 0:29
  • I find it sort of works. I figured out that I have to modify the EPSG in the xml file. But, I'm not getting all of the detail that I need. All the other parameters are greek to me. – Justin Dec 30 '14 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.