1

This is my first time having such trouble, but I'm only a casual user.

I have a base raster layer of the school I work for and I've been adding vector shapefiles on top of that in separate installments. I made a map of trails and the shapefiles from that show up on the view and layer list. I then add a vector layer of flower beds and as soon as I do that the trails disappear from the main view. The CRS is the same, the Trails are still listed in the Layers and I've brought them to the top of the layer list. I can select them from the attribute table but they still don't show up. Removing the flower beds layer doesn't fix the issue, I need to start a new project to get the Trail layer to show again.

The flower bed layer doesn't cause the topography layer to disappear which is another line shapefile I've reused from another project. I've also added another line layer and point layer on top of the flower beds and they don't disappear.

I've tried this in QGIS Valmiera and Brighton on a Windows XP and Ubuntu machine respectively and the issue is the same.

Any ideas what's going on?

1

You have to keep an eye on the extent and CRS of your layers. You can look that up with rightclick on the legend entry -> Properties -> Metadata tab.

Layers that have an extent of within +/-180/90 are in a geographic CRS (like WGS84) using degrees as units; while all others use projected CRS like UTM or State Plane in meters or feet or what is used in your part of the world.

If you have assigned a wrong CRS to your data, it will not align with other layers, even when On-the-fly-reprojection is enabled. Layers might disappear, if the reprojection of the coordinates fails. Use rightclick -> Set CRS for Layer to switch from the wrong CRS to the right one.

I suggest to set Project CRS to EPSG:3857, and select an Openstreetmap or Google Layer from the Openlayers plugin to see which of your layers are in the right place.

  • Thanks, I was under the impression that the CRS layers all had to match, but I guess since I drew them in different formats they had to be in their native projection. Toggling them between EPSG: 4326 and EPSG 3729 until they showed up solved the problem. – Dan Coppock Jan 19 '15 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.