1

I am attempting to load and draw a WFS layer from geoserver. It is installed on a Windows 2012 Machine. I have enabled CORS and I am able to draw and query WMS layers without fail. Below is my syntax for the layer

var vectorSource = new ol.source.ServerVector({
  format: new ol.format.GeoJSON(),
  loader: function(extent, resolution, projection) {
    var url = 'http://gis.halker.com:8080/geoserver/sandbox/wfs?service=WFS&version=1.1.0&request=GetMap&layers=sandbox:junk__poly&styles=&bbox='
     + extent.join(',') + ',EPSG:4269';
    $.ajax({
      url: url,
      dataType: 'jsonp'
    });
  },
  strategy: ol.loadingstrategy.createTile(new ol.tilegrid.XYZ({
    maxZoom: 19
  })),
  projection: 'EPSG:3857'
});

var loadFeatures = function(response) {
  vectorSource.addFeatures(vectorSource.readFeatures(response));
};

// Vector layer
var vectorLayerFixed = new ol.layer.Vector({
  source: vectorSource,
  style: new ol.style.Style({
    stroke: new ol.style.Stroke({
      color: 'green',
      width: 2
    })
  }),
  name: 'vectorLayerFixed'
});

I believe this is correct because in firebug I am getting errors that lead me to believe something is being requested. the error is as follows.

<ows:ExceptionReport xmlns:ows="http://www.opengis.net/ows"

I am really up a creek here because this is well beyond my understanding. I have looked over stack exchange and can't find anything I can make sense of.

  • At least GetMap is not a WFS request. It belongs to WMS. Try what happens with GetFeature. – user30184 Dec 24 '14 at 23:00
  • We need to see the rest of the Exception report with the actual error in it to be able to help. – Ian Turton Jul 30 '17 at 16:27

Browse other questions tagged or ask your own question.