1

I have a model in ModelBuilder that takes a shapefile, runs some tools on it, adds it to a geodatabase, applies symbology from a layer file and converts it to a KMZ. It all works fine except for the "Apply Symbology from Layer" tool.

I created a smaller model for testing the problem sections which is shown below. The original input feature class is a geodatabase. When I run this model, it runs and says it completes successfully, however my symbology is not applied to the layer.
enter image description here

The Input Layer and Symbology Layer are both point files, so that should not be the problem. When I manually import the Symbology Layer (outside of ModelBuilder), it displays fine, so I don't think it's an issue with the layer file.


I tried to revise my model based on suggestions from Mapperz and MollyS. Here is my revised model and screenshots of the two Properties windows but I am still unable to get a KMZ with the symbology. Any ideas what I am doing wrong? enter image description here

  • 1
    Use 'Layer to KML' instead with the symbol preset. – Mapperz Dec 29 '14 at 17:19
  • @Mapperz Thanks, I did not know about the symbol preset. I think I'm looking in the right place (per MollyS's answer below), but something is still not working right for me. I posted some additional information in my question showing what I tried. – Sara Barnes Dec 29 '14 at 21:10
1

Is there a reason you have to use the "Apply Symbology From Layer" tool? I usually do this through the context windows. You can set the layer symbology for the output "SurveyEvidencePoint" by right-clicking "SurveyEvidencePoint", selecting properties, and then setting the path to your layer file.

  • Thanks, I was unaware of these settings. I found them but they are still not producing a KMZ with my layer symbology. I posted some additional info in my question if you can take a look. Thanks! – Sara Barnes Dec 29 '14 at 21:09
  • I figured out what was causing my problem. I had done a join on my layer earlier in the model, so the field name in my table did not match that in my symbology layer. I was able to fix this by adding a new field with the same name as my symbology layer and calculating it from the previously joined field. – Sara Barnes Dec 31 '14 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.