I have been looking for this for a while and can't find the answer: when you startup geoserver a webpage is opened at localhost:8080/geoserver/web but if you have changed your port config in jetty.xml then this is the wrong address... still, when you start up geoserver opens the page at 8080, which fails now of course...

here is my question: where is this behaviour set in geoserver?

while i am at it, is it possible for geoserver to autostart?

thanks in advance

update: this is for running geoserver on an OSX Machine

  • Have you tried configuring the port in $TOMCAT/conf/server.xml, because you can change the port there from 8080 to your desired port. That is at least where I changed it when I last used it, but that is a tomcat config file and not the jetty one it looks like you are using.
    – dkroy
    Commented Jul 29, 2011 at 4:40
  • sorry if my question is not clear. i HAVE changed to port to 8088 and it works fine if i open localhost:8088/geoserver/web. the problem is that starting the server still opens localhost:8080/geo.. which now corresponds to nothing. it's annoying each time i start the map server to have to see this error instead of the webapp
    – Barnabe
    Commented Jul 29, 2011 at 6:56

2 Answers 2


Are you running on osx? I take it you are referring to how on startup it opens the browser to the GeoServer homepage? That port is actually hardcoded and you can't change it so it is a bug. Feel free to open an issue in the bug tracker.

  • 1
    yes I am on OSX. you can actually edit jetty.xml in contents/Resources/Java/etc/ and change the default port as below <Call name="addConnector"> <Arg> <New class="org.mortbay.jetty.nio.SelectChannelConnector"> <Set name="port"><SystemProperty name="jetty.port" default="8088"/></Set> <Set name="maxIdleTime">30000</Set> <Set name="Acceptors">2</Set> <Set name="confidentialPort">8443</Set> </New> </Arg> </Call> my install of geoserver runs on 8088 because it otherwise conflicts with port forwarding 8080.
    – Barnabe
    Commented Jul 29, 2011 at 6:31

Old thread but just for others with this issue:

I had this problem running Geoserver via Eclipse, I tried changing <jet.port> in the pom.xml, but this had no effect.

However; the solution is in the docs:

  1. Open the Arguments panel of the Start configuration [..]
  2. Specify the -Djetty.port parameter, setting it to the desired port

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.