1

In ModelBuilder i want to make a lot of service area layers. The input data would be the same but the day of time would change every time. So from 6:00:00 untill 22:00:00 i created already a table with the different times (in format date) (see figure 2) and add this table into the model (see figure 3)

now when i add %Value% in the field day of time (see figure 4) and click next on the button ok.. nothing happend, the field of day of the time is again empty..

So how could i run the tool 'make service layer' for different time steps?

value_service layer

time table

time in model

And how does it works to change the output name automatic?

1 Answer 1

1

Niels,

Looks like a bug in model builder. I was able to replicate the problem too. But I did find a simple solution.

  1. In the image below note that my date values have a date component and not just a time.
  2. In the Make Service Area Layer tool I added %n% to the layer name to give each layer a unique name ending with a number (the number of times the model had run), your current set up will overwrite, may be you wanted that, something to be aware of?
  3. I was able to connect the output of the iterator to the time of day parameter by using the connect tool and not writing %Value%. Why that would work and not the usual in-line substitution I have no idea!
  4. Output of iterator was set to Date type.

Modelbuilder example

1
  • It works, thank you! BTW: if you chose in the field 'day of time ' time only , it's possible to work only with hours and not with the date
    – niels
    Jan 6, 2015 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.