2

I have two problems with QGIS 2.6.1

1) When i am trying to open command line i get error:

An error occurred during the execution of Python code:

Traceback (most recent call last): File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\ProcessingPlugin.py", line 134, in openCommander self.iface.mapCanvas()) File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\gui\CommanderWindow.py", line 48, in init self.commands = imp.load_source('commands', self.commandsFile()) UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 17: ordinal not in range(128)

2) When i am trying tu run external algorithm SAGA, GRASS whatever i get message:

Missing dependency.This algorithm cannot be run :-( This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS Click here to know more about how to install and configure SAGA to be used with QGIS

  • 1
    Welcome, please give more details: OS seems to be windows, 32 or 64 bit?, qgis 32 or 64 bit? – Kurt Jan 5 '15 at 21:47
  • QGIS is usually pretty good at downloading and installing dependencies... do you perchance have more than one python install? Perhaps SAGA is installed to a different python install location. Apart from that you could try uninstall/re-download/install. – Michael Stimson Jan 5 '15 at 22:13
  • 1
    Did you check the Processing settings to see if the application paths point to the correct install locations? – underdark Jan 5 '15 at 23:28
3

Thanks for help. I found solution. The problem was in windows user account with polish characters. I have changed user and everything is ok now.

  • You should accept your answer if it solved your problem as it will remove this question from the Unanswered section :) – Joseph Apr 27 '15 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.