1

Just installed postgres 9.3 + postgis 2.1 on debian 7.

Postgis works fine, but installation of PGrouting fails in psql.

(no errors while installing sudo apt-get install postgresql-9.3-pgrouting)

But this SQL:

CREATE EXTENSION pgrouting;

gives

ERROR: could not load library "/usr/lib/postgresql/9.3/lib/postgis-2.1.so": /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/libproj.so.0)
SQL state: 58P01
Context: compilation of PL/pgSQL function "pgr_startpoint" near line 1

Any suggestions?

I also tried the combination postgresql 9.2 with postgis 2.0, same problem.

hans

  • Where did you get the pgRouting Debian package from? Is it in the official Debian repository? – dkastl Jan 7 '15 at 17:26
  • I installed the pgrouting like this, first I added to /etc/apt/sources.list this line: deb ftp.de.debian.org/debian sid main and then: sudo apt-get update sudo apt-get install postgresql-9.3-pgrouting There where no errors. I also tried the combination postgresql 9.2 with postgis 2.0, same problem. – Hans Jan 7 '15 at 18:19
  • I just found out that before I try to install pgRouting, PostGis functions work fine, but after the installation of pfRouting PostGis fails. SO somehow the installation of postgis (apt-get install postgresql-9.3-pgrouting) has inpact on the installation of PostGis. – Hans Jan 7 '15 at 19:53
  • I can only speak for the Ubuntu PPA for pgRouting, because I maintain it, and there is no problem. Unfortunately I have no knowledge about the Debian package and who manages it. – dkastl Jan 8 '15 at 0:55
  • I installed unbuntu and tried to install pgrouting, but there seems to be an other problem with the packages. I added the ppa.launchpad.net to the sources.list, but then apt-get update fails with: Failed to fetch ppa.launchpad.net/ubuntugis/ppa/ubuntu/dists/trusty/main/… 404 Not Found any idea? – Hans Jan 8 '15 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.