1

CentOS release 6.5 (Final) Linux version 2.6.18-028stab101.1 (root@rhel5-build-x64) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-46)

I'm trying to Install Cartaro CMS (http://cartaro.org/). GeoServer, Postgresql and PostGIS are up and running.

The only missing software requirement to install Cantaro is the GDAL-PHP extension. I've spend hours to resolve the dependencies but after successfully compiling the gdal.so, "make test" fails with the following warning:

PHP Warning: PHP Startup: Unable to load dynamic library '/tmp/php5-gdal-0.1.3/modules/gdal.so' - /tmp/php5-gdal-0.1.3/modules/gdal.so: undefined symbol: _ZN17GDALDriverManager10MoveDriverEP10GDALDriveri in Unknown on line 0

  • PHP_SAPI : cli
  • PHP_VERSION : 5.4.36
  • ZEND_VERSION: 2.4.0
  • PHP_OS : Linux - Linux 268.xxx.de 2.6.18-028stab101.1
  • INI actual : /tmp/php5-gdal-0.1.3/tmp-php.ini
  • More .INIs :
  • CWD : /tmp/php5-gdal-0.1.3
  • Extra dirs :
  • VALGRIND : Not used

  • SKIP Test: OGRGeometry [tests/ogrgeometry.phpt]

  • FAIL Test: Version number [tests/version.phpt]

I've compiled the actual stable vesions of gdal (1.9.2) and proj4 (4.8.0) by following these instructions:

https://github.com/wavded/ogre/wiki/Compiling-a-recent-ogr2ogr-from-source-on-CentOS-%28RHEL%29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.