I am trying to login to the http://myserver/arcgis/rest/admin page and when I log in with credentials I get no error message but I am returned to the same login page. If I put in bad credentials I get an error message saying bad login. I can login to the rest/services page and the ArcGIS Server Manager Site.

I found this but I am not sure if this applies http://forums.esri.com/Thread.asp?c=204&f=2388&t=257171

It looks like I am using a reverse proxy..from looking in the rest.config file under the rest directory. Does anyone have a clue on what I should investigate?


When you are returned to the same login page, do you get an address like:

I am not sure the reason, but sometimes when I try to directly access a REST admin page, it goes to this redirect loop. If you end up here, try accessing the page you want directly, e.g.
You will be asked to login again, but when you do it should then redirect you to the correct page.


Take a look at your event-view logs; you will often see .Net level errors inserted there that may help you see the issue.

For sure make sure you are logging in with a account that is a member of the agsadmin group on the server.

  • I am logging on with an account that is part of the agsadmin group. I have created a GIS server admin connection from ArcCatalog and I can log into AGS Manager. Thanks..I will check the .Net level errors.
    – Justin
    Aug 2 '11 at 2:49
  • 2
    Also, I've found that your login name is case sensitive.
    – kenbuja
    Aug 2 '11 at 13:55
  • Yes, it does get matched.
    – D.E.Wright
    Aug 3 '11 at 0:52

I marked blord-castillo as correct but I did not test but it was redirecting me. I had ArcGIS Server 10 SP1 and SP2 installed ( I was told this was addressed in one of them) and it worked. Install the service packs blord-castillo if you can and report back...thanks guys.

  • We have SP1 installed right now, so I guess that must mean SP2 fixes it. I found the problem to be fairly random; I can only occasionally generate it by trying to access pages inside the admin console directly. Since I rarely do that, I rarely run into the problem. Aug 3 '11 at 14:19

Ran into this issue today - changing to use the correct port (and SSL) solved it, e.g. https://myserver:8399/ArcGIS/rest/admin/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.