2

i am doing an export a New Data Layer but when i tried to save it that's what happened enter image description here

enter image description here

what's wrong?

5
  • 1
    Have you tried saving with extension ".shp"?
    – phloem
    Jan 8, 2015 at 19:40
  • Please write the error messages in the thread to make enable search engines to index this question and the answers.
    – underdark
    Jan 8, 2015 at 19:46
  • Does this file location exist? You cannot create a folder while exporting (I get the same error trying to do so).
    – phloem
    Jan 8, 2015 at 19:58
  • It looks to me like you changed the name of the Output Feature Class in between your first screenshot and your second one, and in the second one it's obscured by the error message so it's impossible to say for sure what the problem is.
    – Dan C
    Jan 8, 2015 at 20:47
  • seems like the is a space in the folder name - try c\:work instead.
    – Mapperz
    Jan 8, 2015 at 21:00

3 Answers 3

2

Often the file type for the export will be set incorrectly for the output location. For example, if you are exporting from a geodatabase, the export type is set to 'Feature Class' and you are trying to export to a generic folder outside of a database, you will get an error (because you can't create a feature class without being inside a database).

Click on the folder icon next to the path and file name on the export dialog box. In the window that opens (see below) make sure that the option in the 'Save as type' drop-down is set to something appropriate (shapefile for a generic folder, feature class for a database).

enter image description here

1

If exporting to the same folder, alter the file name to something like "new_governaret_export".

Or, create a new folder for exports and you can keep the same filename.

1

Have you try to first save selected data and later export the data as a shp? W/ the right button on the shp> select> save selected, it will create a "virtual" shp w/ your data, next pick your data and save it as you are doing right now.

i hope this solve your problem (i dont have now a arcGIS so not sure of the route is 100% exact but the steps yes)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.