1

how to make roads in open_street_map ready for network_analyze in Arcgis-10.1 Details: I'v download an osm map of my town I saved the street lines as polyline shapefile I opend them in arcgis-10.1 I made the network dataset and add it to arcmap When I try to make a network anlyse to find the shortest route for 3 or 4 points I got an error message that the lines (street polylines) are not snapped well. So I can find the shortest route for some points (where the polylines are snapped well) but can't do that for far away points. Now Is there any way to solve this problem?? Can I do any kind of "automatic" snapping for all the polylines??

  • Can you be more specific about your problem? – scai Jan 9 '15 at 20:29
  • 1
    Sometimes it's easier to drop the network and build a topology. Then use topology rules to find violations. Or if you want to program, you can identify dangles (where valence = 1) without much effort. gis.stackexchange.com/questions/48265/… – Kirk Kuykendall Dec 1 '15 at 23:25
1

I really think you should have a look at ESRI's "ArcGIS Editor for OpenStreetMap". It includes a tool to build Network Datasets from OSM data:

http://www.esri.com/software/arcgis/extensions/openstreetmap

Shapefiles are kind of "deprecated" in the world of ArcGIS. I recommend using the tools included in the toolbox, and a File Geodatabase for storage of the data, which gives you much more options.

Note ESRI is currently working on a new release of the toolbox, with quite a lot of fixes. It may be worth waiting for that, and upgrading to ArcGIS 10.3 or so in the process...

  • Thanks for responding, i used OSM toolbox to make a Network Dataset from *.osm file and i used the (DriveGeneric.xml) and (DriveMeters.xml), but i got an error in result, – user3503064 Jan 15 '15 at 14:01
  • To be honest, I never used the tools for creating a Network Dataset as included in the OSM Toolbox myself, as I don't do routing stuff. You may wish to report your issue at the Github issue tracker of ESRI for this toolbox: github.com/Esri/arcgis-osm-editor/issues. They may be able to help you out there. – Marco_B Jan 17 '15 at 20:25
1

The lines in your shapefile aren't connected properly and thats why the error is occuring.

You can solve the issue in a few different ways. The first one is trying to build the network dataset. If the network dataset (ND) contains unconnected lines or edges it'll raise an error. If you click on the Show Build Errors button you'll get an overview of the unconnected lines (see screenshot). Edit your shapefile in order to connect them.

Network dataset build report

The second solution is to create a topology of the shapefile. Here is a nice tutorial: http://www.esri.com/news/arcwatch/1112/learn-how-to-create-a-map-topology-in-arcgis101.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.